OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Drag link question

  1. #1
    Patrol Guru Chubba's Avatar
    Join Date
    Oct 2013
    Location
    Adelaide
    Posts
    812
    Thanks
    622
    Thanked 614 Times in 339 Posts
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Drag link question

    The old ball joints where shot so today I replaced the drag link bar with a heavy duty one. Now the original one wasn't adjustable but the new one is. I did all the measurements and angles as close as I could to the original by a couple of mills, put the bracket on for the damper and all sweet. But I think that now for some reason my full right lock doesn't seem to be as far as it use to be. The left full lock is fine. Would anyone have heard of this happening before? I'm going to get a wheel alignment.
    98' Ti, 4.5L, 2" lift, factory rear diff lock with front E-locker, 63% reduction gears
    "GO YOU CROWS"

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

     

  3. #2
    Legendary GQtdauto's Avatar
    Join Date
    Dec 2016
    Location
    Northeast Victoria
    Posts
    3,003
    Thanks
    5,074
    Thanked 1,868 Times in 1,250 Posts
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Wheel alignment will sort it all out or should sort it all out .

  4. The Following User Says Thank You to GQtdauto For This Useful Post:

    Chubba (10th September 2017)

  5. #3
    Moderator MudRunnerTD's Avatar
    Join Date
    Jun 2010
    Location
    Geelong
    Posts
    14,034
    Thanks
    10,338
    Thanked 11,050 Times in 5,685 Posts
    Mentioned
    232 Post(s)
    Tagged
    1 Thread(s)
    I wouldn't have thought it would make any difference. As long as your wheels where pointing straight ahead when you took off the old one and bolted the new one you have made no change at all. Is it the same Steering damper? has that been installed in its neutral position?
    Its a Nissan! =====> Its a Keeper!! ....... Got a TD42 in it BONUS!! ....... I'm a lucky bugger! I've got 2 of em!
    Check out my Toy --> MudRunnerTD's GQ From the Ground Up

    Quote Originally Posted by Rogue Dung Beetle View Post
    Wish it was Nissan though, Toyotas just can't keep up with the Pootrol pace.
    The only good thing about an 80 series is..... the front end?? Wrong!!, the Engine?? Wrong!! the Full Time 4WD system?? Wrong!! Its the NissanPatrol.com.au stubby holder fitted over the transfer lever.
    WARNING: Towballs used for recoveries can, and do kill people and damage property.

  6. The Following User Says Thank You to MudRunnerTD For This Useful Post:

    Chubba (11th September 2017)

  7. #4
    ......... MB's Avatar
    Join Date
    Nov 2015
    Location
    Yarra Valley
    Posts
    5,373
    Thanks
    13,641
    Thanked 6,352 Times in 2,951 Posts
    Mentioned
    324 Post(s)
    Tagged
    0 Thread(s)
    Yep, it happened to me too. I stuffed up and had the new adjustable ends on arse about. The nut was hitting on the passenger side and holding back full right lock. It was the blokes doing the wheel alignment that picked it up for me :-)

  8. The Following User Says Thank You to MB For This Useful Post:

    Chubba (11th September 2017)

  9. #5
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    13,409
    Thanks
    6,593
    Thanked 8,308 Times in 5,092 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by MB View Post
    Yep, it happened to me too. I stuffed up and had the new adjustable ends on arse about. The nut was hitting on the passenger side and holding back full right lock. It was the blokes doing the wheel alignment that picked it up for me :-)
    This and just check the small steering stopper bolt on the back side of either swivel hubs. These are known to work lose. A common tell tale sign of these working lose is you lose some of your turning angle.

  10. The Following 2 Users Say Thank You to mudski For This Useful Post:

    Chubba (11th September 2017), growler2058 (11th September 2017)

  11. #6
    Patrol Guru Chubba's Avatar
    Join Date
    Oct 2013
    Location
    Adelaide
    Posts
    812
    Thanks
    622
    Thanked 614 Times in 339 Posts
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by MB View Post
    Yep, it happened to me too. I stuffed up and had the new adjustable ends on arse about. The nut was hitting on the passenger side and holding back full right lock. It was the blokes doing the wheel alignment that picked it up for me :-)
    You got it MB. Read your reply and went straight out to check. I swear a had the R on the driver's side but must have stuffed up. The lug for the nut and bolt to tie the ball joint to the drag link, at full right lock hits up against the Panhard bush on the left side. So off it comes to flip it around. Seems to be a common thing with me. Almost every fu#@ing job I do on the car has to be done twice because of something stupid like that. Anyway for anyone else replacing their drag link with an adjustable one with the heavy duty female tie rod ends make sure the bolts are on the forward edge.
    Cheers for the responses people.
    98' Ti, 4.5L, 2" lift, factory rear diff lock with front E-locker, 63% reduction gears
    "GO YOU CROWS"

  12. The Following 5 Users Say Thank You to Chubba For This Useful Post:

    AB (11th September 2017), GQtdauto (11th September 2017), growler2058 (11th September 2017), MB (11th September 2017), mudski (11th September 2017)

  13. #7
    SPAMINATOR growler2058's Avatar
    Join Date
    Feb 2011
    Location
    Shed
    Posts
    22,677
    Thanks
    14,465
    Thanked 12,182 Times in 6,481 Posts
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Chubba View Post
    You got it MB. Read your reply and went straight out to check. I swear a had the R on the driver's side but must have stuffed up. The lug for the nut and bolt to tie the ball joint to the drag link, at full right lock hits up against the Panhard bush on the left side. So off it comes to flip it around. Seems to be a common thing with me. Almost every fu#@ing job I do on the car has to be done twice because of something stupid like that. Anyway for anyone else replacing their drag link with an adjustable one with the heavy duty female tie rod ends make sure the bolts are on the forward edge.
    Cheers for the responses people.
    D1ckbrain!!
    IF YA DONT GET STUCK YA AINT TRYIN HARD ENOUGH........OR YA TOOK THE CHICKEN TRACK
    WARNING: TOWBALLS USED WITH SNATCHSTRAPS DO KILL!!
    My GenUine TOUGH Patrol 07 DX CRD Turned into a COMMY UTE!!


  14. The Following User Says Thank You to growler2058 For This Useful Post:

    Chubba (11th September 2017)

  15. #8
    SPAMINATOR growler2058's Avatar
    Join Date
    Feb 2011
    Location
    Shed
    Posts
    22,677
    Thanks
    14,465
    Thanked 12,182 Times in 6,481 Posts
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mudski View Post
    This and just check the small steering stopper bolt on the back side of either swivel hubs. These are known to work lose. A common tell tale sign of these working lose is you lose some of your turning angle.
    Exactly what happened to me
    IF YA DONT GET STUCK YA AINT TRYIN HARD ENOUGH........OR YA TOOK THE CHICKEN TRACK
    WARNING: TOWBALLS USED WITH SNATCHSTRAPS DO KILL!!
    My GenUine TOUGH Patrol 07 DX CRD Turned into a COMMY UTE!!


  16. #9
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    13,409
    Thanks
    6,593
    Thanked 8,308 Times in 5,092 Posts
    Mentioned
    351 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by growler2058 View Post
    Exactly what happened to me
    Yeah Hodge and Nic had the exact same issue too....

  17. #10
    Patrol God
    Join Date
    May 2013
    Posts
    5,945
    Thanks
    4,647
    Thanked 4,632 Times in 2,628 Posts
    Mentioned
    138 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by mudski View Post
    Yeah Hodge and Nic had the exact same issue too....
    Yup I had very limited left or right turn can't remember which.
    Went to mudskis to pick up some parts and mentioned the turn issue to him and within seconds he was under there pointing to a bolt that was literally few threads of working it's self completely loose.

    Sent from my SM-G920I using Tapatalk
    2005 TD42TI

  18. The Following User Says Thank You to Hodge For This Useful Post:

    growler2058 (12th September 2017)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •