OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Results 1 to 5 of 5

Thread: 2000patrol zd30 loss of power after 6 sec

  1. #1
    Beginner
    Join Date
    Mar 2018
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    2000patrol zd30 loss of power after 6 sec

    Hi everyone,
    My names gav,got a problem with zd30.direct injected. After 6sec of excelleration I loose all boost. I then take foot off and back on then boost returns. I have replaced every thing under bonnet. No engine light appears therefore no codes.please help .cheers.
    &

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

     

  3. #2
    I am he, fear me the evil twin's Avatar
    Join Date
    Jun 2010
    Location
    W.A. (wandering aust)
    Posts
    6,266
    Thanks
    874
    Thanked 6,344 Times in 3,181 Posts
    Mentioned
    38 Post(s)
    Tagged
    1 Thread(s)
    I reckon it's going into limp mode.

    Define "Ive replaced everything"... does that include Boost Sensor, cleaned Maf Sensor etc?
    Last edited by the evil twin; 9th March 2018 at 01:32 PM.
    Dolphins are so smart that within a few weeks of captivity, they can train people to stand on the very edge of the pool and throw them fish.

  4. The Following User Says Thank You to the evil twin For This Useful Post:

    JackCollo (9th March 2018)

  5. #3
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 68 Times in 51 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    2000patrol zd30 loss of power after 6 sec

    Quote Originally Posted by Jacko71 View Post
    Hi everyone,
    My names gav,got a problem with zd30.direct injected. After 6sec of excelleration I loose all boost. I then take foot off and back on then boost returns. I have replaced every thing under bonnet. No engine light appears therefore no codes.please help .cheers.
    &
    Hey gav hope your well I can tell you exactly what this is mate. This will be your car going into limp mode like the evil twin said. Do you have a boost controller on the car. There is a boost sensor on the inter cooler this reads the boost within the intercooler and has a cutout boost of 16psi which sends the car into limp mode. Well more of a limiter the revs sit about 2000 rpm and no matter how much gas you give it no increase.

    Unless you have your boost set to a really high setting that’s the only thing I know to set the sensor off.
    My patrol did it when I got a Dawes kit for it but after fiddling around with the boost setting it was perfect never went off again

    Cheers
    Jack


    Sent from my iPhone using Tapatalk
    Last edited by JackCollo; 9th March 2018 at 01:25 PM.
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

  6. #4
    Patrol God threedogs's Avatar
    Join Date
    Jun 2012
    Location
    Melb
    Posts
    33,199
    Thanks
    10,230
    Thanked 9,793 Times in 7,317 Posts
    Mentioned
    103 Post(s)
    Tagged
    2 Thread(s)
    If you still run the OE Intercooler and its oily its leaking, dont bother repairing it buy a fully
    tig welded on from say Diesel Smart, they are 33% bigger as well then you need to know whats
    happening under the bonnet like boost and egts usually in a pillar pod or dash pod. Have a read up on NADS
    a must for any ZD30
    04 ST 3lt auto, not enough Mods to keep me happy, but getting there

  7. #5
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 68 Times in 51 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by threedogs View Post
    If you still run the OE Intercooler and its oily its leaking, dont bother repairing it buy a fully
    tig welded on from say Diesel Smart, they are 33% bigger as well then you need to know whats
    happening under the bonnet like boost and egts usually in a pillar pod or dash pod. Have a read up on NADS
    a must for any ZD30
    No better words spoken from anyone TD mate


    Sent from my iPhone using Tapatalk
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

  8. The Following User Says Thank You to JackCollo For This Useful Post:

    threedogs (10th March 2018)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •