OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ZD30 glow plug issues?!?

  1. #1
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 67 Times in 50 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    ZD30 glow plug issues?!?

    Hey guys
    So last night made the switch from ceramic to metal tipped glow plugs mainly because my old ones weren't working and on a cold morning even after letting them warm the car still takes 30 seconds of cranking before it fires up with heaps of white smoke out the back. Now since I changed the plugs last night I thought this morning it would fire straight up and to my disappointment it did the same thing as before. I have replaced the ecm relay under the dash and checked the 80A fuse for the plugs but they just ain't working??

    Any ideas at all any input is greatly appreciated

    Cheers
    Jack
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

     

  3. #2
    Banned
    Join Date
    Apr 2011
    Location
    Greenbank QLD
    Posts
    3,505
    Thanks
    561
    Thanked 1,540 Times in 1,114 Posts
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Have you checked the voltage on the glow plug busbar when the glow plugs are on?

    The glow plugs main fusible link is 100amp not 80amp.

    Metal tipped glow plugs won’t last long on a ZD30DI if you haven’t done the glow plug timer mod.

    Have you tried pumping your fuel primer before staring when cold?
    Last edited by Yendor; 26th May 2017 at 04:37 PM.

  4. #3
    Expert Daveyboyjunior's Avatar
    Join Date
    Feb 2015
    Location
    Dartmoor, England
    Posts
    138
    Thanks
    24
    Thanked 68 Times in 36 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    He's fitted metal tipped glows Yendor, does he still have to do the mod?

  5. #4
    Banned
    Join Date
    Apr 2011
    Location
    Greenbank QLD
    Posts
    3,505
    Thanks
    561
    Thanked 1,540 Times in 1,114 Posts
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by Daveyboyjunior View Post
    He's fitted metal tipped glows Yendor, does he still have to do the mod?
    It's because he fitted metal tips he will need to do the mod. Sorry I will change my original post.

  6. #5
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 67 Times in 50 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Haven't done the mod yet. Anybody out east/southeast I can pay to do it not comfortable doing it yet.

    Will check the 100 amp fuses
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

  7. #6
    Banned
    Join Date
    Apr 2011
    Location
    Greenbank QLD
    Posts
    3,505
    Thanks
    561
    Thanked 1,540 Times in 1,114 Posts
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Changing the glow plugs to another type won’t fix your problem if they weren’t faulty.

    @mudski might be able to help you with the mod.

  8. #7
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 67 Times in 50 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    So one of the 100 amp fuses has blown but i have no idea what set it off. It's the fuse closest to the motor next to the fuel filter
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

  9. #8
    Banned
    Join Date
    Apr 2011
    Location
    Greenbank QLD
    Posts
    3,505
    Thanks
    561
    Thanked 1,540 Times in 1,114 Posts
    Mentioned
    25 Post(s)
    Tagged
    1 Thread(s)
    Quote Originally Posted by JackCollo View Post
    So one of the 100 amp fuses has blown but i have no idea what set it off. It's the fuse closest to the motor next to the fuel filter
    That’s the glow plug main fuse.

  10. #9
    Expert Daveyboyjunior's Avatar
    Join Date
    Feb 2015
    Location
    Dartmoor, England
    Posts
    138
    Thanks
    24
    Thanked 68 Times in 36 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yendor View Post
    It's because he fitted metal tips he will need to do the mod. Sorry I will change my original post.
    that means i'll have to do the mod.
    whats the problem that requires the mod in the first place?

  11. #10
    SkippyGU JackCollo's Avatar
    Join Date
    Dec 2016
    Location
    Melbourne VIC for now
    Posts
    269
    Thanks
    45
    Thanked 67 Times in 50 Posts
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I've been told a lot of different things about the timer mod. Is it 100% necessary or is it more a choice.

    Got a new 100amp fuse and will battle through to swap that over and get back to you.
    If it blows again I have no idea what I'm gonna do.
    Currently own a ZD30 2000 GU patrol with a dead injector pump about to start a build on a TD42 motor to go in the car and basically rebuild the whole car into a machine of a rig

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •