OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Results 1 to 2 of 2

Thread: rev counter and glow plug not working

  1. #1
    Beginner
    Join Date
    Dec 2021
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    rev counter and glow plug not working

    Hi all,
    I have a 2006 GU TD42 and the rev counter and glow plug have both stopped working at the same time, I am hoping someone out there can help out,
    TIA

    Hubewdy

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

     

  3. #2
    Moderator MudRunnerTD's Avatar
    Join Date
    Jun 2010
    Location
    Geelong
    Posts
    15,071
    Thanks
    11,648
    Thanked 12,911 Times in 6,370 Posts
    Mentioned
    300 Post(s)
    Tagged
    1 Thread(s)
    Not sure about the glow plug, have you checked your fuses? the Tacho sender is on the front of the motor under the thermostat housing.
    Its a Nissan! =====> Its a Keeper!! ....... Got a TD42 in it BONUS!! ....... I'm a lucky bugger! I've got 2 of em!
    Check out my Toy --> MudRunnerTD's GQ From the Ground Up

    Quote Originally Posted by Rogue Dung Beetle View Post
    Wish it was Nissan though, Toyotas just can't keep up with the Pootrol pace.
    The only good thing about an 80 series is..... the front end?? Wrong!!, the Engine?? Wrong!! the Full Time 4WD system?? Wrong!! Its the NissanPatrol.com.au stubby holder fitted over the transfer lever.
    WARNING: Towballs used for recoveries can, and do kill people and damage property.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •