OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Results 1 to 7 of 7

Thread: 98 nissan patrol air mass issue

  1. #1
    Beginner
    Join Date
    Aug 2021
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    98 nissan patrol air mass issue

    I have nissan patrol 98 4.5 i have problems with air flow senser i have replaced it with new one still have code p0100 and lot of black smoke and engine shutdown it self after 2 second

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

     

  3. #2
    Patrol Freak jff45's Avatar
    Join Date
    May 2012
    Location
    Morayfield, QLD
    Posts
    1,332
    Thanks
    271
    Thanked 848 Times in 530 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    If the MAF sensor isn't the problem then it's likely to be an issue in the wiring circuit or the plug. You'll need to check that the MAF is getting a 5v signal and, if so, check that the varying voltage between 0.5v (approx.) and 5v is getting back to the ECU.
    John

    2001 GUII TI 4500 - Now converted to TD42T auto with Nomad valve body

  4. #3
    Beginner
    Join Date
    Aug 2021
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can i have wiring diagram for maf sensor
    Coz the wire broke

  5. #4
    Patrol Freak jff45's Avatar
    Join Date
    May 2012
    Location
    Morayfield, QLD
    Posts
    1,332
    Thanks
    271
    Thanked 848 Times in 530 Posts
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    My mistake, MAF has 12v not 5v. Confusing it with TPS.

    This is the diagram from the factory manual.


    9EC2DB62-1E49-4D78-94CB-9A182BEFA1D4.jpeg
    John

    2001 GUII TI 4500 - Now converted to TD42T auto with Nomad valve body

  6. #5
    Patrol Freak BillsGU's Avatar
    Join Date
    Jul 2010
    Location
    Thurgoona
    Posts
    1,166
    Thanks
    39
    Thanked 551 Times in 357 Posts
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Years ago I had a faulty MAF sensor replaced and the problem was still there. After a lot of head scratching the brand new sensor was found to be faulty. If you know someone with the same type of Patrol just swap their sensor to see if it works.

  7. #6
    Beginner
    Join Date
    Aug 2021
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tried same issue
    Now garage guy says need new ecu

  8. #7
    Beginner
    Join Date
    Aug 2021
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Finely got it working no black smoke but there is back fire 😢😅

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •