OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Results 1 to 3 of 3

Thread: Possible Carter pump failure?

  1. #1
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    14,029
    Thanks
    7,080
    Thanked 9,068 Times in 5,466 Posts
    Mentioned
    375 Post(s)
    Tagged
    0 Thread(s)

    Possible Carter pump failure?

    Dumb question. Should I be getting a closed circuit from the +ive terminal on the pump to the body of the car when everything is switched off?
    IMG_3934.jpg

    Still trying to find the cause of my oil pressure switched coming on dim. As the pump only runs when the oil pressure light goes off I.e creating a closed earth circuit to which the pumps neg is connected too...

    Thanks.


    Sent from my iPhone using Tapatalk

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

     

  3. #2
    The 747 Winnie's Avatar
    Join Date
    Dec 2011
    Location
    Newborough, VIC
    Posts
    15,332
    Thanks
    6,771
    Thanked 11,213 Times in 5,839 Posts
    Mentioned
    182 Post(s)
    Tagged
    1 Thread(s)
    Yes that circuit should be closed but there should be no voltage through it.

    Sent from my SM-G986B using Tapatalk

  4. The Following User Says Thank You to Winnie For This Useful Post:

    mudski (22nd January 2021)

  5. #3
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    14,029
    Thanks
    7,080
    Thanked 9,068 Times in 5,466 Posts
    Mentioned
    375 Post(s)
    Tagged
    0 Thread(s)
    Cheers mate. Thought so. Just having a brain fade moment trying to sort this gremlin out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •