OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Page 4 of 4 FirstFirst ... 234
Results 31 to 32 of 32

Thread: GU won't start

  1. #31
    Legendary GQtdauto's Avatar
    Join Date
    Dec 2016
    Location
    Northeast Victoria
    Posts
    3,624
    Thanks
    4,989
    Thanked 1,844 Times in 1,235 Posts
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Still at the shop ,went ok for 20 Kay's then stalled again it's sucking air at the filter housing so replaced filter housing primer with a new one and now the GU has cracked the shits big time .
    Seems to be sucking the fuel out of the filter leaving it dry ( empty) so bit of a mystery unless there's problems now (still) further back in the tank maybe .
    Mechanic is going to leave it for a few hours restart it and try cracking the injector lines to get whatever air is in it out and go from there .
    Just to add insult to injury Bursons who sent the filter housing and pump down from Sydney it went missing from Monday to yesterday grrrrrrr.

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

     

  3. #32
    Legendary GQtdauto's Avatar
    Join Date
    Dec 2016
    Location
    Northeast Victoria
    Posts
    3,624
    Thanks
    4,989
    Thanked 1,844 Times in 1,235 Posts
    Mentioned
    41 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Cuppa View Post
    Try one of these in addition to a new filter top one. Makes priming so much easier. Not all are diesel compatible. This one is cheap too. Mine, (not this specific one) has been on several years now, but if it ever fails it's easy to take out of the line & rejoin.

    https://www.ebay.com.au/itm/Hand-Pri...-/162709827636
    Are thinking of an electronic pump thanks though .

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •