OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Results 1 to 6 of 6

Thread: Motor running on after key turn

  1. #1
    Beginner
    Join Date
    Jul 2019
    Posts
    8
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Motor running on after key turn

    Good morning. We have minor or major issue in our ute I hope you good people might be able to shed some light on. Last 3 or 4 days our motor keeps on spinning even after key turn and eventually dies a slow rumbly shutdown. Usually its key turn & it goes to sleep. Now it takes 7-8 seconds. Of most concern is that last few seconds she gets really violent and lumpy. My self and the good o'l wife are on with the ages, and it scared the pigs out of her old bones mentally and physically when it happened the first time.

    The original owner (our boss) said he has never had anything like this prior. I witnessed a runaway diesel in a hino back in karatha and it wasnt nice. This came to mind first and a symptom ? Am I looking in the wrong bag here?

    The pig in question is a 06 ute ti td42.

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Posts
    Many

     

  3. #2
    Expert 0-TJ-0's Avatar
    Join Date
    Jan 2017
    Location
    South Australia
    Posts
    352
    Thanks
    240
    Thanked 223 Times in 139 Posts
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    I wouldn't expect it to be as serious as that. The fuel pump has an electronic shut off solenoid. Perhaps that's just not doing it's job properly?
    2003 GU TD42 with a few extra ponies

  4. #3
    Expert
    Join Date
    Aug 2012
    Location
    sunshinecoast
    Posts
    198
    Thanks
    0
    Thanked 48 Times in 42 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    most diesels have a throtle valve ( a plate that is fully open when engine is running or fully closed when ignition is turned off ) . i would think on your model it would be vacum operated . they can sometimes stick open . you may be able to see it happen if you locate the valve and watch it when the ignition is turned off , it should close quickly as soon as the key is turned . if it wont the motor can run on . this is the main purpose for the valve being there . you could also be haveing problems with leaky injectors , maybe try some injector cleaner as well . the throttle valve is usually connected to the inlet manifold .
    Last edited by nipagu7; 19th July 2019 at 11:09 AM.

  5. #4
    Expert 0-TJ-0's Avatar
    Join Date
    Jan 2017
    Location
    South Australia
    Posts
    352
    Thanks
    240
    Thanked 223 Times in 139 Posts
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by nipagu7 View Post
    most diesels have a throtle valve ( a plate that is fully open when engine is running or fully closed when ignition is turned off ) . i would think on your model it would be vacum operated . they can sometimes stick open . you may be able to see it happen if you locate the valve and watch it when the ignition is turned off , it should close quickly as soon as the key is turned . if it wont the motor can run on . this is the main purpose for the valve being there . you could also be haveing problems with leaky injectors , maybe try some injector cleaner as well . the throttle valve is usually connected to the inlet manifold .
    No such thing on the 4.2. There is a butterfly for the egr system but it never fully closes.

    May also be caused by leaky injectors?
    2003 GU TD42 with a few extra ponies

  6. #5
    Legendary Rossco's Avatar
    Join Date
    Jun 2010
    Posts
    3,680
    Thanks
    6,267
    Thanked 4,823 Times in 2,016 Posts
    Mentioned
    128 Post(s)
    Tagged
    0 Thread(s)
    Hey mate, sounds like the fuel cut solenoid to me, usually gives those kind of symptoms. .

    Sent from my SM-G930F using Tapatalk

  7. #6
    Hardcore
    PeeBee's Avatar
    Join Date
    Sep 2016
    Location
    Melbourne South east
    Posts
    2,804
    Thanks
    2,404
    Thanked 2,219 Times in 1,389 Posts
    Mentioned
    122 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Rossco View Post
    Hey mate, sounds like the fuel cut solenoid to me, usually gives those kind of symptoms. .

    Sent from my SM-G930F using Tapatalk
    Agree Rossco
    Manufacturer of the Complete Camp Oven System

    Website:http://davesstuff.net/

    Vendor Page: http://www.nissanpatrol.com.au/forum...ar-That-Works/

    Tuturial Video's: http://www.nissanpatrol.com.au/forum...ted-on-Youtube

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •