OUR VIDEOS GALLERY MEMBER SPONSORSHIP VENDOR SPONSORSHIP

User Tag List

Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Fault Code PO123 - Came about after Exhaust change from stock to 3"

  1. #11
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks all, will check everything, replace vacuum hoses, and adjust the psi, post back results

  2. # ADS
    Circuit advertisement
    Join Date
    Always
    Location
    Advertising world
    Posts
    Many

     

  3. #12
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quick update,

    I have fixed some issues I had with the boost controller, re adjusted the boost psi and replaced the vacuum and boost lines.

    The fault code and throttle response issue are still happening but only randomly now ??

    Have found a replacement throttle body for $700 which is heaps better than Nissan price but still aren't ready to buy it,

    Thinking I might pull this one out and try and clean it all up , maybe its a bit gummed up with carbon and stuff ??

    Any ideas ??

    Thanks

  4. #13
    Expert
    Join Date
    Aug 2012
    Location
    sunshinecoast
    Posts
    183
    Thanks
    0
    Thanked 46 Times in 41 Posts
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    many people run catch cans to remove most of the blowby going into the inlet manifold . if the throttle body is gunked , after you clean it up , you might want to consider this as it will help keep your maf sensor and intercooler cleaner as well as the throttle body

  5. #14
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Good idea , I was thinking of a bigger intercooler aswell so might do both at the same time, start off fresh and clean...

  6. #15
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi All,

    Update , I ended up fitting a SH throttle body last night and all problems seem to be gone.

    The vehicle drives and responds like a whole different beast , itís never driven as smooth since I have owned it.

    Ended up getting one for $220 from a wrecker in vic.

    Hopefully itís the end of the electrical dramas

  7. #16
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    13,158
    Thanks
    5,683
    Thanked 7,356 Times in 4,580 Posts
    Mentioned
    291 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by R055IE View Post
    Hi All,

    Update , I ended up fitting a SH throttle body last night and all problems seem to be gone.

    The vehicle drives and responds like a whole different beast , itís never driven as smooth since I have owned it.

    Ended up getting one for $220 from a wrecker in vic.

    Hopefully itís the end of the electrical dramas
    Throttle body or Throttle position sensor, thats fitted to the acc pedal?

  8. #17
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi Mudski , I changed the throttle body on the engine

  9. The Following User Says Thank You to R055IE For This Useful Post:

    mudski (2nd May 2019)

  10. #18
    In Moderation
    mudski's Avatar
    Join Date
    Apr 2012
    Location
    Eltham North
    Posts
    13,158
    Thanks
    5,683
    Thanked 7,356 Times in 4,580 Posts
    Mentioned
    291 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by R055IE View Post
    Hi Mudski , I changed the throttle body on the engine
    Sweet. Was the original one full of oily black soot?

  11. #19
    Advanced
    Join Date
    Apr 2019
    Location
    Kalgoorlie , WA
    Posts
    39
    Thanks
    4
    Thanked 11 Times in 8 Posts
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Had a bit in it but not caked up , butterfly still moved freely with no obvious sticking points , air pipe from intercooler had a bit of oil in it aswell , not heaps but enough to be leaking out around the clamps , bit of obvious oil and crud in the intake manifold after the throttle body

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •